95 Grand Am blower fan issue

Reply

  #1  
Old 07-29-14, 11:27 AM
Member
Thread Starter
Join Date: Jul 2014
Location: United States
Posts: 2
95 Grand Am blower fan issue

I have replaced the relay, the fuse inside the car, the resistor and the switch and it still will not turn on. What else could be the problem?
 
Sponsored Links
  #2  
Old 07-30-14, 12:02 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,027
Welcome to the forums.

You didn't change the motor yet.

Do you have a 12v test light ? If not..... get one. It's a lot cheaper than changing everything.
Look for 12v on both sides of the fuse, at the switch, at the motor and the resistor block.

I'm assuming that this is strictly a basic heating system with no electronic control.
 
  #3  
Old 07-30-14, 02:35 PM
Member
Thread Starter
Join Date: Jul 2014
Location: United States
Posts: 2
Blower issue on 95 Grand AM

I have checked the blower and it is good. It works when I had it tested at the parts store. If I have replaced the relay, the fuse, the switch and the resistor what else could it be? it is my daughters car and she will need it for college soon.
 
  #4  
Old 07-30-14, 05:36 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,027
There may actually be two relays...... one for 12v power and a second one for hi speed fan.

I don't know what else can be bad. I check the circuit before I change any parts. You need to find out if you actually have +12v in the circuit.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:05 PM.