bad fan switch

Reply

  #1  
Old 09-13-14, 11:51 AM
Member
Thread Starter
Join Date: Sep 2014
Location: United States
Posts: 2
bad fan switch

we have a 2000 pontiac grand am.....the fan switch is not working properly....at first the low speed (1st 3 speeds on the dial) would not work but the fan worked on high speed....then it quit working altogether....then the fan wold come on even with the car turned off and kill the battery.......i finally pulled the fuse....how do i go about fixing/replacing the switch....is there more involved than just replacing the switch.... Thanks
 
Sponsored Links
  #2  
Old 09-13-14, 12:02 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 46,946
There is a resistor block and possibly a hi speed bypass relay. I would start by changing the resistor block which is mounted to the duct work, just to the left of the motor, and behind the glovebox.

This video may be helpful to you.... you tube/watch?v=F034sa859Vw
 
  #3  
Old 09-13-14, 12:41 PM
Handyone's Avatar
Forum Topic Moderator
Join Date: Aug 2000
Location: U.S.
Posts: 5,451
the resistor block which is mounted to the duct work, just to the left of the motor, and behind the glove box
Yes,
I've changed a few of these. When you do get the old one out, you'll see it looks a little "burnt".
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes