Rear windshield wiper not working


  #1  
Old 02-08-15, 01:43 PM
B
Member
Thread Starter
Join Date: Aug 2008
Location: peru, illinois
Posts: 44
Received 0 Votes on 0 Posts
Unhappy Rear windshield wiper not working

I have a 2004 gmc envoy xuv the rear wiper quit working, I don't have an owners manual to check it out to she what is going on with it any help will be appreciated, oh one more thing where can I find an owners manual for a 2004 gmc envoy xuv thanks for any help
 
  #2  
Old 02-08-15, 01:57 PM
G
Member
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,295
Received 2 Votes on 2 Posts
First check your fuses. Next test is to wire a test light up to the wiper motor. If the bulb does not light or the light intensity does not vary as you change the speed settings, the switch may be bad. If the light does vary, replace the wiper motor.
 
  #3  
Old 02-11-15, 08:03 PM
A
Member
Join Date: Feb 2015
Posts: 9
Received 0 Votes on 0 Posts
Good advice from goldstar. Its either a switch, fuse or motor. Hopefully just a fuse.
 
  #4  
Old 02-12-15, 06:03 AM
W
Member
Join Date: Feb 2006
Location: USA
Posts: 6,783
Received 34 Votes on 31 Posts
Manual

Is this the manual you wanted?

http://www.vadengmpp.com/owners-manu...-GMC-Envoy.pdf
 
  #5  
Old 02-12-15, 06:09 AM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 48,155
Received 405 Votes on 361 Posts
Rather than getting an owner's manual I'd suggest getting a repair manual for your vehicle as it will have more detailed info on making the repairs you'll likely have to make along the way.
 
  #6  
Old 02-12-15, 06:20 AM
A
Member
Join Date: Jan 2013
Location: U.S.A.
Posts: 2,113
Received 72 Votes on 65 Posts
Don't know, but I would suspect that there might be a second switch at the tailgate, to prevent the wiper from operating when the gate is open. Just thinking that if there is that might be most susceptible to physical damage.
 
  #7  
Old 02-12-15, 11:50 AM
Join Date: Jun 2010
Location: Canada (near The Motor City)
Posts: 699
Received 11 Votes on 8 Posts
Did the wiper get sluggish, slow down over time and one day not work at all.
Or did it just up & quit out of the blue?
 
  #8  
Old 02-15-15, 11:23 AM
B
Member
Thread Starter
Join Date: Aug 2008
Location: peru, illinois
Posts: 44
Received 0 Votes on 0 Posts
rear wiper not working

thanks for the info. I will try all the suggestions and will try the web site for the owners manual thanks again big hammer
 
  #9  
Old 03-01-15, 03:07 PM
B
Member
Thread Starter
Join Date: Aug 2008
Location: peru, illinois
Posts: 44
Received 0 Votes on 0 Posts
rear wiper not woking

it was a simple fix had a blown fuse thanks for all the help big hammer
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: