need some help 1995 ford Taurus stalls after starting

Reply

  #1  
Old 02-27-15, 06:25 PM
Member
Thread Starter
Join Date: Feb 2015
Location: USA
Posts: 3
need some help 1995 ford Taurus stalls after starting

was running great next morning i went to get in and go somewhere and it started but as soon as i gave it some gas it bogs out and stalls. we have checked the fuel filter and the pump seems to be running fine as gas is getting to the engine. it will start and idle for a few it's just when you give it gas it stalls out sometimes it does make a pop sound through the tail pipe. someone told me it might be the catalytic converter but i do not want to buy one and have it put in without really knowing if it's that. any suggestions on what it might be that a grandmother of 50 can do herself. i have tools and am able to get greasy.lol
 
Sponsored Links
  #2  
Old 02-27-15, 06:41 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,010
Welcome to the forums. (we'll have to call you greasy grannie)

It wouldn't be the catalytic convertor.

The fuel rail pressure should probably be checked. You'd need a screw on pressure gauge for that.
But it sounds mostly like an EGR(exhaust gas recirculation) valve problem.
 
  #3  
Old 02-27-15, 07:19 PM
michaelshortt's Avatar
Forum Topic Moderator
Join Date: Mar 2002
Location: Washington State
Posts: 787
Check for codes, that may save you a lot of money
 
  #4  
Old 02-27-15, 07:33 PM
Member
Thread Starter
Join Date: Feb 2015
Location: USA
Posts: 3
Thank you both Michael and PJ. am going to check on the Valve. will let you all know how it turns out. Greasy Grannie
 
  #5  
Old 02-28-15, 03:52 AM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 43,017
A plugged cat convertor robs the engine of power but it would still run.
If you can limp it down to your local auto parts store most of them will read your codes for free.
 
  #6  
Old 02-28-15, 06:08 AM
Join Date: Jun 2010
Location: Canada (near The Motor City)
Posts: 589
Is it a 3.0 or 3.8 engine?
Did this symptom happen "all of a sudden"?
How many miles on vehicle? Have plugs, wires etc been checked/serviced regularly?
 
  #7  
Old 03-07-15, 05:23 PM
Member
Thread Starter
Join Date: Feb 2015
Location: USA
Posts: 3
3.8 and yes all of a sudden drove fine night before then went to go to the Dr. and it would not stay started. have changed the plug/wires oil change and EGR valve and tubes. still won't stay running. idles for a few sec. then dies. i am stumped and autozone don't carry the code reader for this car. Greasy Granny is pulling her hair out. what little she has left. LOL
 
  #8  
Old 03-07-15, 06:22 PM
michaelshortt's Avatar
Forum Topic Moderator
Join Date: Mar 2002
Location: Washington State
Posts: 787
My 94 thunderbird is the same way, most code readers won't work. Might find a good mechanic and pay to read the codes. Might save you money in the long run.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:19 PM.