My car will start, but won't stay runnung

Reply

  #1  
Old 06-18-15, 02:13 PM
Member
Thread Starter
Join Date: Jun 2015
Location: usa
Posts: 2
My car will start, but won't stay runnung

I have an 03 Grand Prix and drove around doing errands today. When I later tried to start it, it would turn over, but died when I took my foot off the accelerator. I would keep running if I had the accelerator to the floor, but that's it. Now my battery is dead and won't charge if my car won't continue to run. I'm at a loss.
 
Sponsored Links
  #2  
Old 06-18-15, 02:56 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
Welcome to the forums! Having the same problem with my '00 Jeep Grand Cherokee. Found out it is the MAP sensor not receiving the 5v it needs to operate. It will show up as code P1296. While I have not fixed mine yet, one person suggested removing the battery cables and let it sit for an hour or so to discharge everything, then hook them back up and let the MAP circuit re-learn itself.
 
  #3  
Old 06-18-15, 03:08 PM
Member
Thread Starter
Join Date: Jun 2015
Location: usa
Posts: 2
Thanks Chandler...I'll give it a shot.
 
  #4  
Old 06-19-15, 01:34 AM
Member
Join Date: Jan 2014
Location: USA
Posts: 699
You probably need to invest in a battery charger , too .

Would a throttle position sensor cause this , too ?

Or the Idle Air Control (IAC) Valve ?

God bless
Wyr
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'