jeep wont start

Reply

  #1  
Old 07-30-15, 08:30 AM
Member
Thread Starter
Join Date: Jul 2015
Posts: 1
jeep wont start

help. 98 jeep grand cherokee. no crank. telltales light up windows work in accessory position, gauges dont move when switched to on position. windows wont roll down in on position. lights dont dim when key moved to start. swapped relays around no change, not able to jump start. very new battery and neg. cable' thinking ignition switch or park/neutral sensor, any help appreciated.
 
Sponsored Links
  #2  
Old 07-30-15, 09:28 AM
Temporarily Suspended
Join Date: Jul 2008
Location: NY
Posts: 10,986
Does the battery have caps, to add water? It sounds stupid but no one checks the water level. I even saw a battery labeled as sealed but still had the caps.
 
  #3  
Old 07-30-15, 10:12 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 43,851
Welcome to the forums.

gauges don't move when switched to on position. windows wont roll down in on position.
Sounds like you lost an ignition supply. It could be a fuse, a relay or the ignition switch.
When I get a problem like yours I take my 12v test light and check EVERY fuse. Under the dash and under the hood.
 
  #4  
Old 07-30-15, 12:00 PM
Join Date: Jul 2015
Location: USA
Posts: 38
Is a barely loose cable possible? That has happened to me before.
 
  #5  
Old 07-30-15, 01:45 PM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
My helper had the same symptoms in his Chevy truck. He had a full battery, but no ignition. All the lights lit up. He replaced the ignition switch, and a host of other things, before he realized it was a miisaligned park/neutral switch. Loosen two screws, move the module, tighten the screws. He felt really bad. He had apparently kicked the switch getting in or out of the truck and caused the misalignment.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'