2002 Saturn SL1 heater does not work

Reply

  #1  
Old 12-08-15, 02:49 PM
Member
Thread Starter
Join Date: May 2008
Location: United States
Posts: 9
2002 Saturn SL1 heater does not work

I have a 2002 Saturn SL1 with a heater that stopped putting out hot or even warm air. It was working fine when I parked it at night but wouldn't heat the next day. There are no leaks. I had a new thermostat installed and the system flushed out and the switch settings checked. Still no heat. The only thing left according to the machanic is the heater core being clogged. I have never heard of a core just causing a stoppage of heat that fast when it was working fine the prior day. Of course that doesn't mean its not possible. Before I pay another $280 I just want another opinion. Any ideas out there?
 
Sponsored Links
  #2  
Old 12-08-15, 02:56 PM
Forum Topic Moderator
Join Date: Mar 2005
Location: USA
Posts: 43,986
Has it been verified whether or not the blend door is opening?
 
  #3  
Old 12-08-15, 04:07 PM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
Follow hoses from engine to heater core at firewall if possible and feel both hoses. Should feel basically same temp when heater on, low fan. If big difference in feel of temperature, look for blockage, or flow valve possibly stuck if system has one.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes