01 ford escape

Reply

  #1  
Old 01-07-16, 11:01 AM
Member
Thread Starter
Join Date: Jan 2016
Posts: 1
01 ford escape

My wife was driving and suddenly the power steering went out, she said it was hard to turn and then she drove for a little bit and then it just went out on her.and her check engine light came on. It would crank over a little bit then not at all wouldn't start. Changed the plugs to try. Found oil in the intake and put some oil in it because it was low. I can't figure out the issue. Any help????
 
Sponsored Links
  #2  
Old 01-07-16, 12:05 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,541
Sounds like it threw the serpentine belt. Check that?
 
  #3  
Old 01-07-16, 01:41 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,222
Is that a timing belt engine? Oil in air intake points towards timing being off and valves not opening/closing when needed.
 
  #4  
Old 01-08-16, 04:33 AM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,541
I checked, Igor, and it's a timing belt engine. Can't see a correlation between that and loss of power steering while engine still running though.
 
  #5  
Old 01-08-16, 10:35 AM
Gunguy45's Avatar
Super Moderator
Join Date: Dec 2007
Location: USA
Posts: 20,937
Hmmmm...never saw the engine mentioned by the OP. Pretty sure the V6 has chain and the 4 a belt. My 2001 Tribute V6 (same as an Escape basically) was a chain.
 
  #6  
Old 01-08-16, 02:32 PM
the_tow_guy's Avatar
Group Moderator
Join Date: Feb 2001
Location: SW Fla USA
Posts: 11,541
The 2.0L 4 cyl is belt. I didn't look for other engine options.
 
  #7  
Old 01-09-16, 05:04 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,222
power loss is simple - loss of engine power leads to loss of power steering. Don't forget who was driving. feedback may be a bit askew
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'