2003 ford escape codes

Reply

  #1  
Old 08-26-16, 09:06 AM
michaelshortt's Avatar
Forum Topic Moderator
Thread Starter
Join Date: Mar 2002
Location: Washington State
Posts: 788
2003 ford escape codes

Have an after market radio that always lost power and would sometimes not come on. I installed it per the instructions and used a wire that always has power in the old radio wires. So I removed the radio and checked all the connections. I decide to go and buy wire and fuse connection to come off the battery. So on my way the radio turns off. I lost power to my key fob and I think the interior lights. Find the 10 amp fuse titled room was blown. Replaced the fuse and all is well. Disconnected the radio until I get time to work on it later. Check engine light comes on. Checked for codes and I got PO 443, 135, 141,155,161 and P2195. Most being malfunction of O2 sensors and Evap Purge vale fault. Checked all fuses and the are all good. Cleared the codes but the come back. Any help would be great, but I am thinking my ECM is damaged.
 
Sponsored Links
  #2  
Old 08-26-16, 12:01 PM
Member
Join Date: Aug 2015
Location: USA
Posts: 300
would probably find a wiring diagram and start testing the o2 heater circuits they may not have power going to them perhaps a bad fuse or damaged wiring but really doubt the ecm is damaged.
once you find the issue with the o2 heater circuits would clear the codes again.
 
  #3  
Old 08-26-16, 12:06 PM
michaelshortt's Avatar
Forum Topic Moderator
Thread Starter
Join Date: Mar 2002
Location: Washington State
Posts: 788
Got it fixed. When I was checking all the fuses I left the Heco fuse out. Fuse installed, drove it for a while no check engine light and no codes.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes