Remote unlock won't work

Reply

  #1  
Old 01-20-17, 08:42 AM
Member
Thread Starter
Join Date: Mar 2009
Location: Philadelphia, PA, USA
Posts: 180
Remote unlock won't work

We have a 1998 GMC Jimmy, and two days ago, began having problems with the remote.

The remote has four buttons -- Lock, Unlock, Rear (unlock) and the red Horn button (sounds alarm).

I tried replacing the battery, cleaning the contacts, and even tried our spare remote. None of the first three buttons work, but the Horn button sounds the alarm.

I'm sure the battery is good (tested), and using the RF sensor at my local hardware store, I can verify that all four buttons are working and transmitting a signal. However, the doors will not lock or unlock using the remote.

The doors lock and unlock fine using the standard button on the door.

I asked my mechanic -- one said it probably needs to be reprogrammed, and other said it's probably the fuse. But I ask you: if it needed to be reprogrammed or it was the fuse, would the horn still work?

Anything I can do to test it further? Is there even a GMC dealer to take it to? Thanks!
 
Sponsored Links
  #2  
Old 01-20-17, 01:54 PM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,189
try doing key relearning procedure. You stand next to driver side door, press and hold Lock+Unlock buttons. After about 5 seconds, locks should cycle lock>unlock.
This happens when battery goes dead and BCM forgets the key.
 
  #3  
Old 01-20-17, 10:43 PM
Member
Thread Starter
Join Date: Mar 2009
Location: Philadelphia, PA, USA
Posts: 180
You are a genius! Thank you! Now to figure out why it "forgot"...
 
  #4  
Old 01-21-17, 07:31 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,189
Ahem, like I said - battery went dead in the fob, transponder lost connection with BCM> BCM forgot the key. It's that simple. Ask me how I know.
GM BCM is known evil minion. It has amazingly mean mind of its own.
 
  #5  
Old 01-21-17, 08:20 AM
Member
Thread Starter
Join Date: Mar 2009
Location: Philadelphia, PA, USA
Posts: 180
Well, not exactly... when I pulled the battery out of my wife's fob and tested it, it was good. And the first thing I did when she said it wasn't working was to hit all the buttons, and the Horn button still worked, so I don't think it was the fob battery. My spare didn't work either.

Either way, we're happy it works, and we'll just have to wait and see if it happens again. We owned the vehicle for 8 years and never had this problem.
 
  #6  
Old 01-21-17, 06:20 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: NJ - USA
Posts: 42,970
If it wasn't working with more than one remote it could be a BCM problem. That could be costly to replace.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:05 AM.