strange cranking / hard starting issue

Reply

  #1  
Old 11-25-19, 05:31 AM
E
Member
Thread Starter
Join Date: Jan 2018
Location: United States
Posts: 26
Received 0 Votes on 0 Posts
strange cranking / hard starting issue

Morning all, I have a 2003 Isuzu Rodeo with about 140k miles. it is a 4x4 with Auto trans. owned about 4 years, no real issues. this morning I turned the key, it cranked but did not start (normally starts with very short cranking time). second try it kept cranking on its own after I left the key go. I turned the key off after a couple of seconds and it stopped cranking. ( this odd cranking happened twice in all the time i've owned it , but only once each time) Over the next 8-10 tries, it cranked on its own maybe two more times. when it finally began to start, very roughly, it spewed out some very smelly exhaust, smelled rich, I'm thinking it was flooded possible from the fuel going in though not starting. Idle appears to be fine, doesnt feel rough, or sound like its idling bad.
The CEL light has been on for a few days, it does come on every couple of months, then goes off on its own after a few days. always hte same codes P0133, and 2 codes for 0420. I cleared the codes, the CEL went off, turned it off, waited a minute, fired it back up, it started just fine this time...was starting to leave for work, but as I picked it up to just over 2k rpms the cell light started to blink until the engine went back down under 2k rpms. I backed up and put it back in the garage. not sure where to begin or what to look at ..

I've been on here before, and have always had great input which is very much appreciated.
 
Sponsored Links
  #2  
Old 11-25-19, 06:10 AM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 6,681
Received 392 Votes on 366 Posts
P0133 is a O2 sensor code, you stated that there was a strong fuel smell, you have a fuel issue going on!
 
  #3  
Old 11-26-19, 07:34 AM
ukrbyk's Avatar
Member
Join Date: Mar 2010
Location: USA/ Pacific NW
Posts: 3,596
Received 12 Votes on 9 Posts
1. start with fixing error codes. Fixing, not deleting, don't behave like ostrich.
2. ignition lock is bad
3. strong fuel smell after all the cranking, I sort of get it. Unburnt fuel. Flooded spark plugs.
Fix the car. Don't drive it, or it will catch you in the least appropriate place and time.
 
  #4  
Old 11-26-19, 05:00 PM
E
Member
Thread Starter
Join Date: Jan 2018
Location: United States
Posts: 26
Received 0 Votes on 0 Posts
could it be leaking injectors? it definatly started like a flooded engine when it did fire up.
 
  #5  
Old 11-26-19, 05:03 PM
E
Member
Thread Starter
Join Date: Jan 2018
Location: United States
Posts: 26
Received 0 Votes on 0 Posts
Ive had the 02 sensors replaced already,. codes still popped up a few months after that, ignition lock bad,.. causing it to not start? or causin it to keep turning over like it did.
 
  #6  
Old 11-26-19, 05:08 PM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 9,029
Received 74 Votes on 67 Posts
Key sticking causing cranking issue.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: