Vent fan stops working

Reply

  #1  
Old 12-18-19, 08:31 PM
D
Member
Thread Starter
Join Date: Feb 2001
Location: United States
Posts: 88
Received 0 Votes on 0 Posts
Vent fan stops working

I have a 2010 Chevrolet Malibu LTZ and the vents on the dash stops blowing air at times. I took the battery cable off and the fan starts blowing air out of the vents. What causes the fan to start back up, when I take off the battery cable and then place it back on? It will blow air for weeks and then do the same thing again.
 
Sponsored Links
  #2  
Old 12-18-19, 08:51 PM
XSleeper's Avatar
Group Moderator
Join Date: Dec 2004
Location: USA
Posts: 26,197
Received 714 Votes on 661 Posts
I would suspect a bad (corroded) ground at some point in the electrical system. Hard to say where it would be. A wiring diagram would be needed, but look for anyplace your wiring is attached to the frame inside the engine compartment, such as on the firewall near the blower motor, passenger side. The liquid ice melt they spray on the roads is horrible on things like this.

When it is working, does the fan switch seem to work on all settings, from hi to low?
 
  #3  
Old 12-18-19, 09:22 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,679
Received 1,172 Votes on 1,087 Posts
It used to be a mechanical thing. A positive position fan speed switch, a resistor block and a blower. Very simple and easy to diagnose.

Now on GM...... there is a blower control module that is powered at all times and the electronics from the heater control and ECM tell it what to do. A common problem is the blower staying on when the key is turned off.
 
  #4  
Old 12-19-19, 07:57 PM
D
Member
Thread Starter
Join Date: Feb 2001
Location: United States
Posts: 88
Received 0 Votes on 0 Posts
Yes. it works on lower and higher settings. Does the blower control module need to be replaced?
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: