Ford 2005 Five Hundred ABS trouble

Reply

  #1  
Old 01-02-20, 12:12 PM
G
Member
Thread Starter
Join Date: May 2003
Location: Brookfield Wi.
Posts: 151
Received 0 Votes on 0 Posts
Ford 2005 Five Hundred ABS trouble

I have a ford five hundred that the ABS light and traction control light stays on.I disconnected the fuse but it still stayed on there is also a fuse for the ABS valves.First was #10 second was #13 where do I go from here
 
Sponsored Links

Popular Reply

 
01-02-20, 01:13 PM
alan73
alan73 is offline
Member
Join Date: Aug 2015
Location: USA
Posts: 587
Received 17 Votes on 16 Posts
need to read codes on abs possibly on pcm also that should give you an indication of why the lights are on may need to clear them and see what returns as you may have caused more codes by pulling fuses.
 
  #2  
Old 01-02-20, 01:13 PM
A
Member
Join Date: Aug 2015
Location: USA
Posts: 587
Received 17 Votes on 16 Posts
need to read codes on abs possibly on pcm also that should give you an indication of why the lights are on may need to clear them and see what returns as you may have caused more codes by pulling fuses.
 
gbpack1950, iceman681 voted this post useful.
  #3  
Old 01-02-20, 08:04 PM
iceman681's Avatar
Member
Join Date: Jul 2012
Location: United States
Posts: 467
Received 3 Votes on 3 Posts
lights will stay on till problem is fixed, there is no other way to turn them off.
 
gbpack1950 voted this post useful.
  #4  
Old 01-02-20, 11:10 PM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 6,354
Received 349 Votes on 325 Posts
Good chance it's a bad ABS sensor, the units themself are very robust!
 
gbpack1950 voted this post useful.
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: