Why the huge price disparity in these two fuel pump modules?

Reply

  #1  
Old 09-17-20, 05:40 AM
A
Member
Thread Starter
Join Date: Sep 2015
Location: United States
Posts: 138
Received 0 Votes on 0 Posts
Why the huge price disparity in these two fuel pump modules?

Our 01 Taurus died while driving yesterday and, as I suspected, it was the fuel pump because it wouldn't start after I pulled over. So here are two I found and I'm wondering how I can justify paying $100 more. What would you choose?



$35
https://www.ebay.com/itm/302420397302



$140
https://shop.advanceautoparts.com/p/...837/10563236-P
 
Sponsored Links
  #2  
Old 09-17-20, 06:28 AM
Marq1's Avatar
Member
Join Date: Sep 2016
Location: USA MI
Posts: 6,562
Received 372 Votes on 347 Posts
One is OEM and one is aftermarket!

Guess you have to look at the cost and hassle factor if the aftermarket went bad!
 
  #3  
Old 09-17-20, 07:42 AM
M
Forum Topic Moderator
Join Date: Mar 2005
Location: USA - N.E.Tn
Posts: 47,663
Received 321 Votes on 285 Posts
I almost always opt for parts that have a lifetime warranty. I'd only cheap out if I was planning to get rid of the vehicle .... maybe.
 
  #4  
Old 09-17-20, 09:38 AM
A
Member
Thread Starter
Join Date: Sep 2015
Location: United States
Posts: 138
Received 0 Votes on 0 Posts
I wound up buying a Delphi from Rock Auto...$95. It's not Motorcraft but it's not an off-brand Chicom either.
 
  #5  
Old 09-17-20, 10:41 AM
B
Member
Join Date: Oct 2015
Location: Ct.,USA
Posts: 1,783
Received 88 Votes on 77 Posts
Another cost to benefit decision of many during a lifetime. And as many decisions are made, important input is not always available. Good luck
 
  #6  
Old 09-18-20, 06:16 AM
T
Member
Join Date: Jun 2012
Posts: 987
Received 13 Votes on 11 Posts
Curious on how you diagnosed a fuel pump issue just because it wouldn't start after you pulled over??
 
  #7  
Old 09-18-20, 07:16 AM
A
Member
Thread Starter
Join Date: Sep 2015
Location: United States
Posts: 138
Received 0 Votes on 0 Posts
I had it towed to my (trustworthy) mechanic and he diagnosed it.

The sending unit has been an issue for at least a year...with wildly erratic fuel gauge readings. And in the last week, I've noticed some sputtering.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: