question on 1995 ford explorer

Closed Thread

  #1  
Old 10-18-01, 08:46 AM
Visiting Guest
Posts: n/a
my RPM is running to high,on the way to work this morning I noticed that when I had my foot on the break the rpm was high and when I would take my foot off the break the car would take off like I had hit the gas. the motor sounded like I was riving up the motor. when I stoped and put it in park, the rpm went up to almost 3. First time it happen was today. Any ideas?
 
Sponsored Links
  #2  
Old 10-18-01, 10:59 AM
Joe_F
Visiting Guest
Posts: n/a
Clean out your throttle body of any carbon.

Likely that the idle air control motor (screwed into the throttle body) is bad. That will cause engine surging and racing.
 
  #3  
Old 10-18-01, 12:42 PM
Member
Join Date: Jun 2001
Posts: 247
Just as Joe says it could be a sticking idle air control valve.It could also be a lower intake leak causing a vacuum leak.We've seen both in the shop but more idle air problems then intakes.Also some of these had recalls for a sticking
throttle body,you might check with your local dealer on it.
 
  #4  
Old 10-27-07, 03:53 PM
Member
Join Date: Jun 2006
Posts: 2
Racing Ford

If the IAC is not connected or bad, you engine will race around 2000rpm+-, so when you take your foot off the brake it dashes forward.

Most issues with the IAC is stalling but when you disconnect the harness to it, your engine will race. Hope this helps
 
  #5  
Old 10-27-07, 05:31 PM
HotxxxxxxxOKC's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2006
Location: USA
Posts: 8,044
This thread is 7 years old!
 
Closed Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes