1999 Ford Expedition - ck susp light

Reply

  #1  
Old 11-18-01, 01:54 PM
Visiting Guest
Posts: n/a
1999 Ford Expedition - ck susp light

I have a 1999 Ford Expedition with the automatic air suspension leveling system. The "ck susp" light is now on, on the dashboard. It doesn't appear as if the air compressor is kicking in. I have swapped the 50a fuse with another and could not move the problem so I believe the fuse is good. Is there anything else I can do before taking it to Ford?
 
Sponsored Links
  #2  
Old 11-18-01, 02:10 PM
Joe_F
Visiting Guest
Posts: n/a
Might be the compressor or the sensors.

Brand new truck, should be warrantied by them, wouldn't mess with it .
 
  #3  
Old 11-19-01, 06:37 AM
Visiting Guest
Posts: n/a
Thanks for the reply. It's going into the dealer on Friday. They indicated it's more than likely a sensor because there haven't been many problems at all with the compressors. Let's hope so. Unfortunately there's 48,000 miles so it's past the warranty period.
 
  #4  
Old 11-19-01, 06:46 AM
Joe_F
Visiting Guest
Posts: n/a
Even if it's past the warranty, it's still too new to require repair to the system.

Talk to the dealer manager and if they won't comply, speak to Ford headquarters in Detroit and maybe they will listen .

Worth trying to get a free repair
 
  #5  
Old 02-25-02, 06:04 AM
royalet
Visiting Guest
Posts: n/a
expedition

Hey i have a 98 expedition and i have 36,000 miles and mines too has just came on, any news from the dealer what was causing this.
 
  #6  
Old 02-25-02, 07:54 AM
Joe_F
Visiting Guest
Posts: n/a
See the reply in my other post.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes