Ford Escort 91


  #1  
Old 01-04-02, 09:08 AM
Guest
Visiting Guest
Posts: n/a
Unhappy Ford Escort 91

I filled up my gas tank with gas having an octane rating of"87"on 31st night as it was party time. Drove like crazy at 80-95mph both ways. My car has only a 1.9L engine and the Speedometer reads 85mps max, I kinda pushed it. Anyways, the car runs fine except it knocks a little. I think its my fuel injector, its clogged, I'm not sure. I got an oil change done, replaced my oil and air filters. Probably get my gas filter replaced. Any suggestions? I have a 107000miles
 
  #2  
Old 01-04-02, 04:42 PM
O
Member
Join Date: Jan 2001
Posts: 93
Received 0 Votes on 0 Posts
Sounds like you might have filled up with bad gas. I would suggest to run a bottle of fuel system cleaner to clean the valves. Also try switching to a different station. I hope this helps. keep me posted.

OM
 
  #3  
Old 01-04-02, 05:07 PM
Joe_F
Visiting Guest
Posts: n/a
Full tuneup if you can't remember the last time it was done. That's a start.

I wouldn't be driving 85 in an Escort. . I wouldn't trust a car like that much over highway speed. Too small .
 
  #4  
Old 01-08-02, 08:03 AM
Guest
Visiting Guest
Posts: n/a
Talking

I tried the Fuel Injector cleaner trick, did'nt seem to fix the problem. Even tried switching to gas type "93" did'nt work. I haven't had time to get the gas filter replaced, too lazy. I'm still driving the stupid thing around as is. I'd probably sell off the car and get a new set of wheels. Escorts are bad news...
 
  #5  
Old 01-08-02, 04:13 PM
Joe_F
Visiting Guest
Posts: n/a
Driving 'em like that they sure are .

Carbon buildup over time will cause knocking under load. Take off the EGR valve and see if the pintle is jammed up with carbon. Clean it, put a new gasket and go from there.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: