Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Won't Start after front suspension repair


koomaster's Avatar
Visiting Guest

Posts: n/a

01-16-02, 01:22 PM   #1  
koomaster
Won't Start after front suspension repair

I have 97 Honda Accord that won't start.

I damaged front wheel recently by hitting the curve a bit hard on the passanger side . The front suspension was repaired and steering rack replaced. The day I got my car back from the shop, it ran fine w/o any problem starting up.
Next morning when I try to start the car, nothing happens. The engine doesn't crank. I got it to start by pushing my car few feet in nuetral. This was Saturday. Next morning, I was barely able to start the engine and drove about an hour. I parked the car for 2 hours and when I try to start it up, absolutely nothing happened. No cranking. I had to jump start it. I checked the battery visually, and saw green light throught hole on the battery.

Any thoughts on this. I never had start up problem with my car until this repair.

Koo

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

01-16-02, 01:30 PM   #2  
Joe_F
If the battery checks out, check for a bad starter or loose connections to it.

If you jump start it and it works, likely a bad battery or an alternator that's discharging it.

 
greez_munky's Avatar
Visiting Guest

Posts: n/a

01-17-02, 10:35 AM   #3  
greez_munky
You might use an ammmeter to see if your are getting power to the starter. Just to make sure there is power getting to it. Just a thought.

 
Search this Thread