Help! No Brakes

Reply

  #1  
Old 01-28-02, 06:55 PM
Visiting Guest
Posts: n/a
Question Help! No Brakes

1989 Plymoth Sundance- Had Broken Right front brake line, Master cylender emptied. Renewed front Brake line, replaced both rear cylinders and renewed and adjusted rear brake shoes(front pads 75%). Gravity fed all 4 brake lines. Here's the problem(ARE YOU READY FOR THIS?)
Start car brake pedal goes to floor. Turn engine off,pump up brakes(they hold) start car while holding brake pedal, pedal goes to floor. Disconnect vacuum line to power booster,start car, pump up brakes(they hold) reconnect vacuum line while holding pedal,pedal immediately pushes to floor. Renewed Booster check valve (same problem) Renewed and bench bled Master Cylinder(same problem).
Could it be the booster(never known one to go bad) or proportioning valve. Running out of money and ideas!
 
Sponsored Links
  #2  
Old 01-29-02, 05:23 AM
Joe_F
Visiting Guest
Posts: n/a
Likely a bad master cylinder at this point.

Verify and double verify you have no hydraulic leaks.

A bad booster gives the opposite effect. The pedal will be rock hard.

If the pedal sinks to the floor, you have a hydraulic, not a vacuum problem!
 
  #3  
Old 01-29-02, 06:15 AM
xiii13
Visiting Guest
Posts: n/a
Had this happen on an '85 Impala. Get another master cylinder. The one I used was bad out of the box, so I ended up doing all the work twice. Second master cylinder was fine.
 
  #4  
Old 01-29-02, 06:54 AM
Joe_F
Visiting Guest
Posts: n/a
Very true and I agree.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:16 AM.