Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Starter, battery, connections? 93 corolla


's Avatar
Visiting Guest

Posts: n/a

02-11-02, 01:12 PM   #1  
Starter, battery, connections? 93 corolla

Two weeks ago i went to start my car and heard nothing but a clicking noise coming from the starter solenoid, so I figured that the starter was not getting enough current. I put the car in gear and got a push and was able to start it. A few days later, after plenty of perfect starts, it did the same thing so i took it to a garage and they told me the battery needed to be changed. I didn't agree with it but let them do it anyway since they were already charging me for the daignosis. Just today the car did it again, a few days after the new battery was installed, but i am not even hearing the solendoid click anymore. I sometimes hear two clicks or so and then nothing. Swtiching the key to "On" without starting turns on the lights on my dash (the brake light, door light, check engine etc.) without attemtping to start the car i try switchin my headlights on and everything goes off. If i switch the key back and turn it back on, i again see the status lights on my dash, i turn my CD player on and turn the volume up half way until ... everything shuts down. I also noticed that my local radio stations got erased so at somepoint i had no charge going at all. Any ideas from anyone as to what to look for. I thought it might be simply the starter but that wouldn't explain what is going on with the lights... (well i think it doesn't)

 
Sponsored Links
trinitro's Avatar
Member

Join Date: Jan 2002
Posts: 1,915

02-11-02, 01:17 PM   #2  
I would lean toward a bad alternator. Take it out and take it to a parts store (Autozone, Murrays) will test it for free.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

02-11-02, 01:53 PM   #3  
Joe_F
Sounds like a bad alternator that is discharging the battery.

See the posts contained in my signature file for more information.

 
mooser1's Avatar
Visiting Guest

Posts: n/a

02-11-02, 02:02 PM   #4  
mooser1
have the alt checked as these guys have suggested.....at the same time, remove and clean both cables to the battery....follow the positive cable to your starter, remove, clean and re-tighten any connections along the way......pay special attention to the connections at the starter solenoid......

 
Search this Thread