95 beretta quit running

Reply

  #1  
Old 02-12-02, 07:19 AM
jz brake
Visiting Guest
Posts: n/a
Question 95 beretta quit running

Hi ! I'm back JZ Brake. I have a 1995 Beretta 3100 Vin# M, auto transmission, and air cond. that was running sluggish. I've checked the fuel filter, it was OK. I checked for water in the fuel, it was OK, fuel pressure was 38 PSI, secondary ignition seems OK, has good spark and ect. I scanned the computer, and came up with code 33, A/F ratio was reading 10.4. I replaced the map sensor, now I have 14.7 A/F ratio. The car is running fine, but I'm stumped, the car will quit running as if you turned the key off, you might drive 5 miles or 25 miles before this happens. I rescanned the computer there is no code and everything looks good. Any ideas will be greatly appreciated.
You can contact me at [email protected]
 
Sponsored Links
  #2  
Old 02-12-02, 07:48 AM
Joe_F
Visiting Guest
Posts: n/a
When it quits will it start right back up again?

Does www.alldata.com show any bulletins on this problem?
 
  #3  
Old 02-12-02, 10:43 AM
mooser1
Visiting Guest
Posts: n/a
I agree, check the TSB's for this vehicle.....lots of later model GM rigs have trouble with faulty ignition switches that have to be replaced.....
 
  #4  
Old 02-14-02, 06:06 AM
jz brake
Visiting Guest
Posts: n/a
joe_F, 95 BERETTA QUIT RUNNING

YES THE CAR START RIGHT BACK UP
 
  #5  
Old 02-15-02, 08:25 PM
jz brake
Visiting Guest
Posts: n/a
Thumbs up 95 beretta is fix

i invested in a snapon 2500 scanner and a 2400 mutimeter,recheck the system. it turned out that the first
map sensor bought from O'reily's was bad, the reason, the sensor held vacuum but would'nt decrease or increase the voltage when the vacuum change.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes