91 hyundai exel DIES!!

Reply

  #1  
Old 03-03-02, 12:38 PM
albochella
Visiting Guest
Posts: n/a
91 hyundai exel DIES!!

I have a 91 Hyundai Exel,I replaced the fuel pump, I don't have a fuel pressure guage bbut it has enough fuel pressure that the pressure regulator stays open when power is on. Pressure regulator is also new. It dies at random. Every time it dies it seems to have fire. I have also replaced the ignition moduleand the coil,plugwires, rotor, cap and probably more that I am forgetting. This has been going on for two months and I can't figure it out. Sometimes it might go 100 miles and seem fine or it might do it as soon as I start it. If threr is water in the gas I can't see it, I have drained the tank twice. Help if you can!
 
Sponsored Links
  #2  
Old 03-03-02, 01:53 PM
Joe_F
Visiting Guest
Posts: n/a
You can't say you have good fuel pressure unless you have a gauge to measure it. Start there!

Autozone rents gauges for free through their rental program.
 
  #3  
Old 04-14-02, 11:02 AM
albochella
Visiting Guest
Posts: n/a
I checked the fuel pressure,(showing 40 lbs) good according to manual.I got a tip from a Hyundai mechanic~ he said when it gets to the no start situation, keep cranking for 10 seconds. I did this and code 22 came up, crankshaft angle sensor. The sensor is in the distributor, I replaced it with one from Autozone. Like new for 50 miles then back to the same thing. They got me a replacement it wouldn't start at all, as a test I went back, got the first one, restalled it and same old thing ran good intermittently. They got me another and it ran great for about 25 miles, now it's doing the same thing! Autozone says my problem lies somewhere else. I have had this car a long time, no one else has worked on it. Wiring conections seem good but will double check ( continuity from distributor to ECU ) Autozone will give my money back ( about 250 bucks) but the same part from Hyundai is about twice that. If I spend that much and it still does the same thing I'll be sick. Oh, by the way it's a 1495cc engine~ forgot to mention that before. Any advise appreciated and sorry about typo's but I don't know how to fix 'um yet!! Later!
 
  #4  
Old 04-14-02, 12:10 PM
Joe_F
Visiting Guest
Posts: n/a
Check some of the links in my signature file for some ideas.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:59 AM.