Toyota Celica 90

Reply

  #1  
Old 03-13-02, 06:47 PM
thai
Visiting Guest
Posts: n/a
Toyota Celica 90

I had just finished doing an complete overhual on my Celica was running fine around the house, but last week I was going to get my celica smogged. While I was driving on the freeway, it was ok. About 6 miles, I exited out and stop at the light about 2 blocks away from the smog checking shop, my car completely shutoff. I turned the ignition off and turned it back. There was nothing, no light, no power of any type not even any light when I opened the door. I checked the battery and fuse, it was fine. So, I had to tow it back home. I hope it not the computer and just some little short. Hopefully, I can get some answers from you Joe Cool. Another question, is ther any testing instrument or tools I can used to find out?
 
Sponsored Links
  #2  
Old 03-13-02, 07:48 PM
Joe_F
Visiting Guest
Posts: n/a
Start by checking my posts and links listed below in my signature file.

Completely dead? No lights, horn, cranking? If so, sounds like a dead battery run down by a bad alternator.

Tell us what you find.

When you say "overhaul", what did you do? You might have left a ground off or something came loose.
 
  #3  
Old 03-15-02, 02:33 AM
thai
Visiting Guest
Posts: n/a
The battery is good and so is the alternator. I found some coolant leaking under the water pipe on top of the transmission. I checked all the ground, it seems to all be connected. I checked all the fuse, there was current flowing through but I don't know why when i open the door there's no light. when I turn the ignition there is no sound completely silence. overhaul-I rebuilt the whole engine.
 
  #4  
Old 03-15-02, 05:17 AM
Joe_F
Visiting Guest
Posts: n/a
You likely left a ground loose or otherwise. Jump/charge the battery now and see if it starts.

How do you know the alternator is good? What's the regulated output at idle with a full load and without a full load?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes