surging-89 ply.voyager-2.5l.F.I.

Reply

  #1  
Old 03-17-02, 10:12 AM
shallowbrook
Visiting Guest
Posts: n/a
surging-89 ply.voyager-2.5l.F.I.

Would appreciate your help before spending a fortune.Recently purchased a 89 ply. voyager-2.5L.-F.I.-turbo. Have replaced all basics. When accelerating at any speed from dead stop or 65m.p.h. engine surges badly as if starving for fuel and then recieving it. Condition continues unless you let up on accelerator or vehicle finally reaches speed you want. If it was carbureted I would diagnose as being faulty accelerator pump but I am at a loss with fuel inj. and all these damned sensors on vehicles now. any advice you can offer would be greatly appreciated. Thanks, ED
 
Sponsored Links
  #2  
Old 03-17-02, 11:14 AM
Joe_F
Visiting Guest
Posts: n/a
Be careful about sinking too much green in an old Turbo heap like this, very poorly screwed together vehicle

That being said, start with my posts and links in my signature file below and tell us what you find.
 
  #3  
Old 03-17-02, 05:17 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,822
Sounds like a bad fuel pump or filter. Check the fuel pressure and see. Not a hard job to do if that's what you need.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes