Car Problem

Reply

  #1  
Old 03-29-02, 05:17 PM
ETLBAY
Visiting Guest
Posts: n/a
Car Problem

I HAVE A 1993 CROWN VIC, V8. 5.0. MY PROBLEM IS THAT MY CAR SMOKES AND IS BURNING OIL, THE CAR RUNS GOOD OTHER WISE
 
Sponsored Links
  #2  
Old 03-29-02, 06:08 PM
knuckles
Visiting Guest
Posts: n/a
The problem is most likely worn valve stem seals. It's a very common problem on the early 4.6L engines.

You can replace the seals yourself if you're an above average DIY mechanic. Otherwise, see your local auto repair shop.
 
  #3  
Old 03-29-02, 06:16 PM
ETLBAY
Visiting Guest
Posts: n/a
Thumbs up THANKS

THANKS YOU

E.T
 
  #4  
Old 03-29-02, 06:25 PM
knuckles
Visiting Guest
Posts: n/a
Question

I just re-read your original post....You say you have a 5.0L engine...hmmm...

I know *some* 1991-up Crown Vics used the 5.8L, but these were police cars & taxi cabs.

What color are the valve covers & does the engine have a distributor?

The 4.6L valve covers are black plastic & there is no distributor.

The 5.0L & 5.8L have either gray steel valve covers or bare aluminum valve covers & the distributor is located in the front of the engine.
 
  #5  
Old 03-30-02, 06:58 AM
Joe_F
Visiting Guest
Posts: n/a
The 1991 vin code G 5.8 engine is carbureted with a pesky Variable Venturi 2 barrel and stops being used in 1991. It is a police/fleet issue only engine.

The last year for the 5.0 in a Town Car is 1991 I believe.

You'll easily know by looking at the Vin # on the dash. If the 8th digit is a W, you have a 4.6.

By the sounds of your problem, you SURELY have a 4.6. Notorious puffers, very poor with oil control.

Knuckles gave you some good advice as well.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes