96ChevyPU Dash/Tranny problems

Reply

  #1  
Old 03-30-02, 09:24 AM
hooknbullet
Visiting Guest
Posts: n/a
Angry 96ChevyPU Dash/Tranny problems

Intermittent problem-sometimes tach & speedo don't work.During this time the transmission will not shift automatically.I also only have 2nd & 3rd in this condition.The service engine light comes on but gives no trouble code.This usually begins at start-up but sometimes will happen while driving.At start-up, if the tach works,it'll be ok.While driving, the first symptom is the speedometer will become very erratic.
Any ideas????
 
Sponsored Links
  #2  
Old 03-30-02, 04:15 PM
Joe_F
Visiting Guest
Posts: n/a
Check www.alldata.com for known bulletins that might match this issue.

Could have a bad speed sensor or an bad ground. I assume that you have rented a scanner to determine there is no code in the computer?
 
  #3  
Old 03-31-02, 04:48 PM
hooknbullet
Visiting Guest
Posts: n/a
I took the truck into a shop once before for this same problem & they "repaired a wire near the fusebox"; It did seem to correct the problem at that time.At that time, there was no hard code from the ECM. Lately, the problem is more continuous than intermittent.(no tach,speedo,odometer,or little red gear selector light, nor will the transmission shift automatically).I'll replace the speedo sensor tomorrow, & I'll also check the ground cable. I haven't experienced any other electrical issues, so is there a dedicated ground strap for that circuit?
 
  #4  
Old 04-01-02, 05:08 AM
redneck
Visiting Guest
Posts: n/a
I have the same truck and if you pull the fuse for the tach,speedo,and odometer, the same thing happens, the truck starts out in second gear and the check engine light appears, but will not pull a trouble code. So my guess would be a bad fuse or bad connection at the fuse block.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes