Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1985 Ford Ff150 PU


Pars's Avatar
Visiting Guest

Posts: n/a

04-15-02, 07:15 AM   #1  
Pars
1985 Ford Ff150 PU

Runs fine most of the time but sometimes dies and won't start.If I wait about an hour it starts again and seems to be ok. I took it to a 'Gateway auto shop' and they couldn't find anything wrong. Could this be the electronic control unit? I don't think they checked that.

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

04-15-02, 07:21 AM   #2  
Joe_F
Could be a number of things. You need to give us more specifics.

Please read the forum's notice at the top of the page for posting guidelines and start by looking at the links in my signature file below.

 
rickwhoo's Avatar
Visiting Guest

Posts: n/a

04-15-02, 07:35 AM   #3  
rickwhoo
most likely

 
Billdo49er's Avatar
Visiting Guest

Posts: n/a

04-15-02, 02:16 PM   #4  
Billdo49er
If you have a hershey bar(ignition module) on the side of the distributor I would look into that being your problem.
When they go bad they usually won't work until vehicle cools down.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

04-16-02, 06:02 AM   #5  
Joe_F
If it's a TFI module like Bill says, you might contact Ford on that.

There was a class action settlement for that problem. A phone call wouldn't hurt.

 
Pars's Avatar
Visiting Guest

Posts: n/a

04-16-02, 07:39 AM   #6  
Pars
Ok, thanks for responding. It is a 1985 ford F150 PU. V8, auto trans, Recent repairs:replaced fuel filter,plug wires,distubutor cap,rotor button. I called Ford and they told me that there was no settlement at this time on the suite.They said that I could bring it in and they could put it on the machine for $59.00.Maybe that would be my best option.The problem seems to be getting worse.Yesterday I parked it while fishing and it wouldn't start a few hours latter.Finally it did start,but died after driving a few miles.Waited about an hour and it started again and I made it home.When this happens it turns over fine,sounds like its starting but doesn't.It's getting gas for sure. Thanks again for the help. If I deside to take it to Ford I'll let you know what they find.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

04-16-02, 07:56 AM   #7  
Joe_F
There IS a settlement claim for some vehicles of this year. Your vehicle may not be affected.

Knuckles furnished the link a while ago. Did you call Ford HEADQUARTERS for an answer (not the dealer!)?

 
Pars's Avatar
Visiting Guest

Posts: n/a

04-16-02, 08:03 AM   #8  
Pars
I didn't call headquarters but I'll try to get in touch with them. I do remember getting a letter a while back about joining a class action suite but the wife told me that she pitched it.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

04-16-02, 08:26 AM   #9  
Joe_F
That was the letter . Fill it out, especially if the module is your problem. Ford will reimburse you for it!

 
Search this Thread