Town Car Oil Change

Reply

  #1  
Old 04-28-02, 12:47 PM
mikejmerritt
Visiting Guest
Posts: n/a
Town Car Oil Change

Hello, 90 Town Car 302CI. Changed the oil and only got 1 1/2 quarts of oil out including what was in the filter. Some oil better than no oil I always say but pulling dipstick showed one quart to much oil. Start it and drain again no more oil will come out. Add two quarts and check, something like two quarts to much. Now I drain again and get one quart and stick shows one quart to much. Where is my oil? Why won't it come out? Car runs fine. Thanks for your time and thoughts.....Mike
 
Sponsored Links
  #2  
Old 04-28-02, 02:14 PM
olehippieinsc
Visiting Guest
Posts: n/a
Town Car oil

Not absolutely sure but it sounds like your oil pan is all sludged
up. Did you try sticking something into the drain hole to see if
more oil would come out? Next thing is to look inside your
radiator!!!!!!!
 
  #3  
Old 04-28-02, 02:58 PM
Joe_F
Visiting Guest
Posts: n/a
Sounds like a clogger to me. How's the oil pressure? Check it with a hand held gauge to be sure.

Betcha the pickup screen is clogged
 
  #4  
Old 04-28-02, 11:02 PM
knuckles
Visiting Guest
Posts: n/a
Lightbulb 2 drain plugs!

Your car has 2 oil sumps & 2 drain plugs. Did you drain BOTH sumps?

The front sump holds approx. 1 quart of oil. The rear sump holds about 3 quarts & the filter holds a quart.
 
  #5  
Old 04-29-02, 09:37 AM
Joe_F
Visiting Guest
Posts: n/a
That is true .

Another brilliant design by the Blue Oval. Knuckles is right. This is likely your problem.

I should remember this. My uncle ruined the engine in his 1979 LTD the same way. He always told my dad, "You know Joe, every time I change the oil not much comes out and the stick always seems high".

After a few year the engine went bad and sure enough, the cause was too much oil. A junkyard engine from a 1980 LTD was fitted and subsquently my dad had to repair this wagon again and the spark plugs were crossthreaded by the factory. Lol.

That car was a bomb from day one. It was built the week of Christmas 1978!
 
  #6  
Old 04-30-02, 06:31 AM
mikejmerritt
Visiting Guest
Posts: n/a
Theres no place like DIY, theres no place......

Hey guys, well just got the red out of my face and the nerve to come back in here. I thought I may have done the oil change on this car myself a time or two but obviously I had not. Wife pointed out I always send it to the quick lube. It does have two drain plugs and my problem was I do this oil change with the car level so I don't have to turn off the air suspension. In that position you can't see the rear plug. I suppose I have changed the oil in everything but a Saab and a Kenworth and have NEVER seen two oil drain plugs. Funny how you can miss some things. Thanks for the input guys and until next time have a great day.....Mike
 
  #7  
Old 04-30-02, 06:35 AM
Joe_F
Visiting Guest
Posts: n/a
No problem. Glad you figured it out. I forgot that too .
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes