annoying sound from engine comparment

Reply

  #1  
Old 04-30-02, 07:05 PM
greez_munky
Visiting Guest
Posts: n/a
annoying sound from engine comparment

I have a '91 S-10 with a 2.5 (manual trans). I've noticed lately that when I press the accelerator down, there is kind of a ringing sound from the engine compartment, the best way to describe the sound is, it sounds just like the chirper on worn down pads sounds like, when it rides on the rotor. I checked into it tonight, I started the engine and went into the engine compartment to see if I could find out where it was coming from, but I am baffled. I am thinking it is one of my pulleys, but I can't be sure. As far as recent repairs go, it has a new alternator in it. Please help.
Greezy
 
Sponsored Links
  #2  
Old 05-01-02, 05:44 AM
Joe_F
Visiting Guest
Posts: n/a
Try disconnecting some of the belts momentarily. If the noise goes away, you know it's one of the belt driven accessories.

Just because you have a new alternator, it doesn't mean it's good. Many parts store units are bad right out of the box.
 
  #3  
Old 05-01-02, 03:27 PM
greez_munky
Visiting Guest
Posts: n/a
yes that is true, but it wasn't replaced just recently (around 3 or 4 monthes ago). It also has a serpentine belt.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes