97 Geo Metro LSI turn signal.

Reply

  #1  
Old 05-09-02, 01:52 PM
cshaner's Avatar
Member
Thread Starter
Join Date: May 2002
Location: Louisville, KY
Posts: 23
97 Geo Metro LSI turn signal.

Hi. Turn signal on my Metro won't blink unless I remove the lamp assembly and bend the wires close to the socket. Would this indicate the socket should be replaced, the wires replaced, or does this indicate a problem somewhere else.
Is there a "low-skill" fix for this or is this something that should be left to a pro?

Thanks in advance,

cshaner
 
Sponsored Links
  #2  
Old 05-09-02, 04:12 PM
rickwhoo
Visiting Guest
Posts: n/a
i would replace the socket. it sounds like the problem.
 
  #3  
Old 05-09-02, 06:43 PM
Joe_F
Visiting Guest
Posts: n/a
Sure does.

Shouldn't be more than a few bucks at any part store or the dealership.
 
  #4  
Old 05-10-02, 02:08 PM
cshaner's Avatar
Member
Thread Starter
Join Date: May 2002
Location: Louisville, KY
Posts: 23
That was it. Toughest part was maneuviring hands/tools in the small area to replace the socket.
FYI, called four auto part stores about the part, they all said about the same thing. GM hasn't released parts to the parts stores yet. Ya gotta go to the dealer. This little socket cost $25.00 at the local dealer.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes