Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Automatic Transmission


tweenie21's Avatar
Visiting Guest

Posts: n/a

05-12-02, 10:02 AM   #1  
tweenie21
Automatic Transmission

I have a 1992 J reg Mercedes 260E, I have just changed the gear box oil and filter as gear changes seems to slip in drive, but ok in 1st and 2nd gears and reverse. Sometimes park position would not engage so I changed the oil as it aid in the Haynes manual.
Since doing that every gear works perfectly except drive pulls away strongly but when it goes to change up to top gear it just starts slipping and the car revs and doesnt change, but if I put it into neutral as I am going along and back into drive it will click into gear until it gets to a certain speed again.
So can you help me out with what is wrong with the car and what needs doing?

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

05-12-02, 12:04 PM   #2  
Joe_F
Sounds like internal failure inside. How many miles on it?

 
storminnorman's Avatar
Visiting Guest

Posts: n/a

05-27-02, 10:44 AM   #3  
storminnorman
So can you help me out with what is wrong with the car and what needs doing?
sounds like it is time for an overhaul of the transmission, make sure that who ever does it does the update to the unit, drills out the rivets on 2 clutch drums and replaces those o rings as they are probably hardened, then taps and uses replacment screws for the rivets. no short cuts to this unit, it is a fine running transmission when properly repaired. my hats of to merceedes the 86 and up sure beats the pants off of the earlier units.

 
Search this Thread