Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Honda Prelude


caddadd's Avatar
Visiting Guest

Posts: n/a

05-18-02, 05:29 PM   #1  
caddadd
Honda Prelude

I have a 93 Honda Prelude with a 2.3L DOHC. It has 60,000 miles and lately I have been having a problem when I am cruising at a steady speed. It acts like it is missing or surging. I have replaces the fuel filter, fuel injectors and the fuel regulator. It seems to be getting worse as now it will miss during acceleration also. I have also replaces the plugs, wires, coil module, distributor cap and rotor. I disconnected the EGR tube and plugged it up to see if there was a difference and there wasn't. The only thing I can think of that is left is the fuel pump or some emissions stuff. Any ideas? I am in need of help!

Thanks

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

05-18-02, 07:16 PM   #2  
Joe_F
Check your fuel pressure with a hand held pressure gauge, and compare it to the spec in the service manual.

Tell us what you find.

 
caddadd's Avatar
Visiting Guest

Posts: n/a

05-19-02, 03:55 PM   #3  
caddadd
Originally posted by Joe_F
Check your fuel pressure with a hand held pressure gauge, and compare it to the spec in the service manual.

Tell us what you find.
Alright, I really feel stupid now. I went through all kinds of testing and purchasing of parts and when I finally was at a complete loss, I decided to start over. I popped open the distributor cap and out fell the rotor into my hand. Apparently the screw that keeps the rotor from flopping around on the shaft came out ant the rotor was just moving around within the cap. I don't know how the engine ran at all! But I retightened the rotor and it runs great now! That was a $700.00 lesson. Always start with the basics first!

Thanks for your help.

 
Search this Thread