body ground

Reply

  #1  
Old 06-04-02, 11:10 AM
M-man
Visiting Guest
Posts: n/a
Unhappy body ground

where is the body ground on my '93 astro? my problem is very
similar to ''rguide.'' when i turn the key, nothing happens. no
radio, gauges, door locks, wipers, etc. all i do have is lights and
horn. like '' rguide,'' i had the battery checked: OK. HELP!!
 
Sponsored Links
  #2  
Old 06-04-02, 11:13 AM
Member
Join Date: Jan 2002
Location: Chicago
Posts: 1,915
This sounds more like a bad ignition switch or a bad main relay then a bad ground...
 
  #3  
Old 06-04-02, 12:02 PM
M-man
Visiting Guest
Posts: n/a
Thank you, Trinitro, for the quick response! What and where is the main relay?
 
  #4  
Old 06-04-02, 01:58 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Check the fusible links at the starter for being melted or corroded.This would cause this problem also.
 
  #5  
Old 06-04-02, 02:49 PM
Member
Join Date: Jan 2002
Location: Chicago
Posts: 1,915
If this only occurs sometimes then it shouldn't be a fusibile link. Most likely it will be a bad switch. I'm not sure where the main relay is in the car, but probably a Chilton's book or an Alldata subscription will locate it for you very quickly.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes