Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

A/C not blowing


Nascar8fan's Avatar
Visiting Guest

Posts: n/a

06-05-02, 08:40 AM   #1  
Nascar8fan
A/C not blowing

I have a 1991 Oldsmobile 88 Royale, engine size unknown! My a/c was making horrible noise for about 2-3 weeks when it was on regardless of what setting it was on, heat or cold. It suddenly stopped blowing air. You can feel cold air when the a/c is on, however, nothing blows out of the vents. I replaced the blower motor yesterday and now the fan will turn manually but still won't turn when the a/c is on. I was told it could be the fan switch. My problem is, don't know where the fan switch is and no one seems to want to help! I don't know that it is the fan switch. Just looking for some assistance!

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

06-05-02, 10:10 AM   #2  
Joe_F
Are you talking about the engine's cooling fan or the blower for the A/C or heat?

Does the vehicle have automatic climate control?

The engine size of the vehicle is a 3.8 in this year.

 
Nascar8fan's Avatar
Visiting Guest

Posts: n/a

06-05-02, 10:31 AM   #3  
Nascar8fan
It is the blower for the a/c and it does have automatic climate control.

Thanks

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

06-05-02, 10:58 AM   #4  
Joe_F
Bring power to the blower motor directly. Does it spin pretty good? If so, the blower motor is fine. If it doesn't, check for restrictions or drag on it. If so, replace it.

That being said, the module that controls the fan could be bad, or it could have a wiped out blower motor resistor. A quick call to any GM dealer will net its location.

 
Search this Thread