Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1986 Cavalier 2.8 Muli- port Injected


ol_dog's Avatar
Visiting Guest

Posts: n/a

06-14-02, 06:38 PM   #1  
ol_dog
86 Cavalier; Stalls out when warmed up.

Stalls out when coming to a stop, after driving for 30-40 minutes. Starts fine,runs fine, only happens after driving awhile. Will start back up after stalling. Plugs are in good shape and the fuel filter is new. Happened three times in one day. Problem does not re-accure on short runs.


Last edited by ol_dog; 06-15-02 at 04:28 AM.
 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

06-14-02, 10:51 PM   #2  
Joe_F
Please see the posting guidelines post at the top of the forum page and repost the requested information.

We need a ton more information to be able to help.

 
easywind's Avatar
Member

Join Date: May 2001
Posts: 516

06-18-02, 11:14 AM   #3  
I had the same problem a few days ago and was diagnosed as a solenoid in the transmission. After it got hot the car wouldn't shift as the transmission was locked in third gear (drive) the car would stall at lights and while going slow. That may be your problem. good luck

 
knuckles's Avatar
Visiting Guest

Posts: n/a

06-18-02, 11:09 PM   #4  
knuckles
I agree on the TCC solenoid diagnosis.

Open the hood, stand directly in front of the car & face the engine. The TCC solenoid connector will be located on the transmission, about 1/2 way down from the top. It's about 1" square and should be blue or white. It's a 4 pin connector, but all 4 pins will not necessarily be used.

Disconnect this connection & road test the car. If the problem goes away, suspect a failed or dirty TCC solenoid.

 
Search this Thread