power brake pump

Reply

  #1  
Old 07-07-02, 02:36 PM
greg starodub
Visiting Guest
Posts: n/a
Unhappy power brake pump

have a 1987 motorhome with a ford 460 4 bbl, 36', utilizes a hydro-max brake system, has a power brake pump, similiar to the power steering pump. The parking brake automatically engages when the vehicle is put into park, parking brake is then released by taking vehicle out of park and then pulling manually on the parking brake handle. I had to replace a seal on the power brake pump, is now reinstalled, all fluids are full. Here is the problem, cannot get the parking brake to release, may have air in the system. Have tried to bleed by loosening bleed screw on the cylinder on the parking brake relay valve system, also have bled through bleed screw at each wheel. Now have no fluid coming from any of these bleed screws when opened, even while depressing brake pedal. Can anyone help? Also, power steering fluid is used in the power brake pump. Vehicle is a 1987 Overland 36 foot Class A, Ford 460, on a John Deere chassis, C-6 transmission.

thanks greg
 
Sponsored Links
  #2  
Old 07-08-02, 04:30 PM
0patience
Visiting Guest
Posts: n/a
Is the park brake on this one an electrical solenoid?
If it is, then when you released the fluid out of the system, the valve may have stuck.
If it the mechanical one, then there may be some blockage in the system.
They used several different units, so it is hard to tell which one you have.

Maybe this post won't get deleted?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes