Abs ?

Reply

  #1  
Old 07-09-02, 06:25 PM
Member
Thread Starter
Join Date: Jun 2001
Location: USA
Posts: 330
Abs ?

I had the left front rotor replaced on my 95 ford ranger after 2 of the studs for the lugnuts broke off. Both sides had the brake pads replaced about a year ago. After doing this the antilock brakes " kick in " almost everytime I apply the brakes while turning. Is this because the left side is stopping better than the right side? Will changing the right side caliper help? Thanks Tim
 
Sponsored Links
  #2  
Old 07-09-02, 06:27 PM
Joe_F
Visiting Guest
Posts: n/a
Did you replace both front brake rubber flexible hoses? They are the likely cause of clogging and brake hang up.

Replace them both, flush out the system bleeding it correctly and see if that improves things.
 
  #3  
Old 07-09-02, 06:32 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Is that the correct rotor for ABS? It may be missing the notches for the sensor to read.

Larry
 
  #4  
Old 07-10-02, 03:54 AM
Member
Thread Starter
Join Date: Jun 2001
Location: USA
Posts: 330
Thanks Joe_F I'll give it a try.
Toyotaman11769 I think its the right rotor. I does have the slotted abs ....thingie.
I just thought this starting right after replacing (1) rotor was kinda funny. I thought maybe there was too much grip on the left side brake causing it to trigger the antilock
 
  #5  
Old 07-10-02, 05:16 AM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
Does it pull ?

Larry
 
  #6  
Old 07-10-02, 01:29 PM
Member
Thread Starter
Join Date: Jun 2001
Location: USA
Posts: 330
No Toyotaman11769 it doesn't. I noticed today that it sometimes it does the antilock thing without even applying the brakes. Or at least it sounds like it is.
 
  #7  
Old 07-10-02, 01:53 PM
Join Date: Jun 2002
Location: Long Island, NY
Posts: 1,531
If it worked fine before you changed the rotor, I would have to go back to that point and see what changed.

Wrong rotor, sensor damaged, metal filings stuck on sensor etc

Larry
 
  #8  
Old 07-10-02, 02:09 PM
Member
Thread Starter
Join Date: Jun 2001
Location: USA
Posts: 330
Good point Toyotaman11769. I had it done by Midas. Normally I would have done it myself but I got lazy. That'll teach me.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes