97 jeep cherokee auto trans


  #1  
Old 10-16-04, 11:49 AM
Pendragon's Avatar
Member
Thread Starter
Join Date: Jul 2002
Location: USA
Posts: 1,851
Received 2 Votes on 2 Posts
97 jeep cherokee auto trans

Heya..

Got a 1997 Jeep Cherokee Sport, 4dr, 4.0 straight 6 with the 4 speed auto.

Anyway, it needs replacing, 1st/reverse planetary is on it's way out. I've already lined up a replacement, but before I get it done, I have another question.

There are 2 wires going to one of several connectors on the trans. One of them is just cut, the other has been cut and the non connector end of the wire grounded to the frame. I'm getting a trans code (I believe it's something on the order of "sensor out of range").

So, why would someone do this? What might these two wires go to, and what effect (on the bad side) might reconnecting them have?

I bought this a while back, I knew the transmission was on it's way out, but it's otherwise in very good condition and I got it at a good price, but those two cut wires have me mystified.

Only other problem with the vehicle is the parking lights on the left side don't work (blinkers and brake lights work though, so the ground is good, as are the bulbs). The reverse lights don't work either. Either or both of these could be due to the wire that was just cut.....

Thoughts?
 
  #2  
Old 10-17-04, 10:10 AM
A
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
Received 0 Votes on 0 Posts
you got it it sounds like the reverse light switch posibly on some chry -jeeps it is also the nutral safety switch means your jeep may start in gear
re conect and see what happens the switch could have been bad and the previos owner could have removed it
 
  #3  
Old 10-21-04, 05:24 PM
Pendragon's Avatar
Member
Thread Starter
Join Date: Jul 2002
Location: USA
Posts: 1,851
Received 2 Votes on 2 Posts
Thought I'd post an update.

Wierd, last night when I got home, the backup lights worked.. this morning they didn't.

I reconnected those 2 wires going to the transmission, reset the check engine light using the OBD software on the laptop and ran about 35 miles of errands... Drove the same, no check engine light.. go figure.. still baffled as to what those 2 wires do. If I can ever get it to the dealer, I'll see if they can find out.

Still have to track down the reverse and parking lights issue. I'm thinking there is a switch near the gear selector, since it did work at least once. In fact, I think I'll go wiggle it around now that it's dark and see if I can get it to come on.. I'll check back in later.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: