1997 Ford Expedition- Windshield wiper handle...

Reply

  #1  
Old 12-30-04, 07:06 PM
ccarpenter1120's Avatar
Member
Thread Starter
Join Date: Jul 2004
Posts: 27
1997 Ford Expedition- Windshield wiper handle...

I have 1997 Ford Expedition and the widshield. It doesn't spray out water when push the washer on the handle. Sometimes you have to turn the wiper on the back to get water to come out the front. Could not find a diagram since this is also the turn signal arm.
 
Sponsored Links
  #2  
Old 12-30-04, 08:10 PM
hogfan's Avatar
Member
Join Date: Oct 2003
Posts: 352
Multifunction Switch?

I think what you are asking is the windshield washer don't work. Most of the time the problem is the multifunction switch. Just remove the wires from the washer bottle motor and check voltage while operating switch.
 
  #3  
Old 12-31-04, 06:01 PM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
most likely the switch is gone but definitly check at the pump like hogfan
said
 
  #4  
Old 01-05-05, 03:50 PM
ccarpenter1120's Avatar
Member
Thread Starter
Join Date: Jul 2004
Posts: 27
it's not the washer fluid pump. I think it's the actual switch in the turn signal arm. Today I noticed the little glow light does not come on. Is there a way to open the turn signal arm?
 
  #5  
Old 01-05-05, 05:31 PM
hogfan's Avatar
Member
Join Date: Oct 2003
Posts: 352
Glow light?

I don't remember any glow light on the multifunction switch? Are you sure that it's not on the trans shifter handle - overdrive light. Plus you can't open that switch and repair it. (multifunction switch) Now if it's the light in the trans shifter handle yes you can buy the light. The top black ring pops off and the switch and bulb pull straight out.
 
  #6  
Old 01-05-05, 07:44 PM
ccarpenter1120's Avatar
Member
Thread Starter
Join Date: Jul 2004
Posts: 27
you are correct, the light on the drive transition arm is out. I still think the problem with the washer is a short in the turn signal arm. How would I fix that?
 
  #7  
Old 01-06-05, 04:25 AM
hogfan's Avatar
Member
Join Date: Oct 2003
Posts: 352
1)Replace the Mulitfunction Switch (wiper,turn signal,head light dimmer switch).phillips screw driver and 20 torx.
2)Also when you have the plastic trim cover off around steering wheel check the wires connected to the trans lever for that light I have seen the wire short out were the wire goes in the handle. I can't remember the fuse number that blows. Sorry!
 
  #8  
Old 01-30-05, 08:28 AM
fender1
Visiting Guest
Posts: n/a
windsheild wiper help 97 Ford Expedition

Last week we had a snow stom and too much ice built up on the drivers side wiper. Before I had a chance to clear it off it stopped moving but the passengers side kept working. Now the drivers side wiper doesn't work when it's in its proper position (flat against the windshield) but if it's propped up (as people do when ice/snow stoms occur) it works. I mean the motion is there meaning it's not the motor (I don't think) b/c it moves left to right when the blade is in the air. Any idea's? Please help!
We have another snow stom on its way.

Thanks
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:34 PM.