'99 Chevy Suburban Fuel Injectors 5.7 Vortec

Reply

  #1  
Old 04-02-05, 09:04 AM
Sparky-L.U.697's Avatar
Member
Thread Starter
Join Date: Feb 2003
Location: Indiana
Posts: 328
'99 Chevy Suburban Fuel Injectors 5.7 Vortec

I just found out I have a bad Injector, but I was told that it was a poppette valve injector and they want to replace the entire CPI unit ($750) . Can't they just replace the faulty injector or is it all one unit as I have been led to believe. Looking at a Jeggs catalogue I could buy aftermarket injectors all day long for $250 (however I did not see any for my particular application).

Can any body provide some additional info as to how this system works and if there are other alternatives to spending $1000 on a motor with 95000 miles on it.

THX
 
Sponsored Links
  #2  
Old 04-03-05, 04:35 PM
billys68ss's Avatar
Member
Join Date: May 2003
Location: USA
Posts: 1,459
Is this the first time you have had this problem? There is a bulletin that states that there is a cleaning procedure that should be performed before replacing anything. According to the bulletin you should not attempt to replace the injectors. This could cause severe problems, especially if you replaced injectors with the wrong type. If the cleaning process does not fix the problem then you should (unfortunately) replace the CSFI system with an updated MFI system?
Depending on your location there is a special cleaner that is to be used as the first attempt to repair this problem.
The product is called a Port Fuel Injector Cleaner and the part number for use in the USA is 12345104. You should be able to get this product from GM as well as ask them about the bulletin. The bulletin number is 00-06-04-003B.
Hope this is helpful to ya,
Billy
 
  #3  
Old 04-04-05, 01:50 PM
Sparky-L.U.697's Avatar
Member
Thread Starter
Join Date: Feb 2003
Location: Indiana
Posts: 328
Thx Billy I will call GM and see what they say.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes