94 blazer


  #1  
Old 05-14-05, 12:58 PM
chucky6295666
Visiting Guest
Posts: n/a
94 blazer

the problem is it wont start it trys but wont keep running it seams like it is starving for gas but it is getting gas what could it be
 
  #2  
Old 05-14-05, 03:03 PM
B
Member
Join Date: Dec 2001
Posts: 2,538
Received 0 Votes on 0 Posts
engine size?
how did you determine it was getting gas?
have you checked for spark at the plug.
 
  #3  
Old 05-14-05, 07:22 PM
WeldGod's Avatar
Member
Join Date: Mar 2003
Location: Texas
Posts: 616
Received 0 Votes on 0 Posts
I would start by checking fuel supply and ignition. I would also have my engine codes read.
 
  #4  
Old 05-15-05, 09:58 AM
chucky6295666
Visiting Guest
Posts: n/a
4.3

the motor is a 4.3
 
  #5  
Old 05-15-05, 10:02 AM
chucky6295666
Visiting Guest
Posts: n/a
94 blazer

Originally Posted by bejay
engine size?
how did you determine it was getting gas?
have you checked for spark at the plug.
its a 4.3 and it is getting spark
 
  #6  
Old 05-15-05, 12:19 PM
B
Member
Join Date: Dec 2001
Posts: 2,538
Received 0 Votes on 0 Posts
check fuel pressure if its a port fuel injected engine it will require 55 psi minimum to start the fact that fuel is coming out of the filter doesnt really tell you anything, a weak pump may be capable of producing 50 psi and cause a no start condition.
 
  #7  
Old 05-16-05, 05:58 AM
A
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
Received 0 Votes on 0 Posts
yes check pressure these 4.3's need exact pressure i have seen then a couple lbs out and cause a no startonce thay get running not as critical try priming the system a few times before starting this may help determin if its a pump or not
 
  #8  
Old 05-31-05, 09:00 AM
chucky6295666
Visiting Guest
Posts: n/a
94 blazer

it was the spider part of the fule injection


thanks for all the help guys
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: