01' Dodge Ram 1500

Reply

  #1  
Old 09-29-05, 03:30 PM
mattison's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Cinti, OH
Posts: 5,548
Received 0 Votes on 0 Posts
01' Dodge Ram 1500

Check engine light came on. Code from AutoZone was PO138: It read Oxygen Sensor Circuit High Voltage Bank 1 Sensor 2.


So my faithful gurus what does this tell me I need to replace ??
 
  #2  
Old 09-30-05, 09:34 AM
A
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
Received 0 Votes on 0 Posts
i says you have to start diagnoseing the O2 circuit the Sensor in question will be the one after the catilitic converter on the left side it is better to replace the in pairs
 
  #3  
Old 09-30-05, 01:03 PM
mattison's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Cinti, OH
Posts: 5,548
Received 0 Votes on 0 Posts
I kinda got the idea that I should simply replace it from someone else also. You say it's best to replace them in pairs? That's cool. Another question...How's Auto Zone for these type parts?


Thanks for the help.
 
  #4  
Old 09-30-05, 09:28 PM
A
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
Received 0 Votes on 0 Posts
i have never dealt with the zone but usually the aftermarket O2s are Perfectly fine I use Bosh sensors all the time with no trouble just make sure that it is for your model not a universal one it makes life much easier to just replace and plug in to oem harness than to use universal and have to wire it up
 
  #5  
Old 10-01-05, 05:26 AM
mattison's Avatar
Member
Thread Starter
Join Date: Mar 2003
Location: Cinti, OH
Posts: 5,548
Received 0 Votes on 0 Posts
I went to the Zone. The 1st one "luckily I opened it 1st" was an original that someone returned ! Had to go to another store and installed it, cleared the code and we'll see what happens. Thanks again for the help. By the way the Zones part was a Bosch.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: