1991 ford F150 Pushbutton Overdrive Problem

Reply

  #1  
Old 06-27-06, 08:24 AM
Member
Thread Starter
Join Date: Jun 2006
Posts: 12
1991 ford F150 Pushbutton Overdrive Problem

My Uncle recently replaced his transmission on a F150 2WD pick up. It runs fine as long as he doesn't have the overdrive engaged. When it is engaged and the engine is warm the O/D tends to slip. I'm wondering if it's a computer or sensor problem?
Any Suggestions?
 
Sponsored Links
  #2  
Old 06-29-06, 08:41 PM
billys68ss's Avatar
Member
Join Date: May 2003
Location: USA
Posts: 1,459
Is this transmission new or rebuilt? Or is it a used trans? It sounds like there is a pressure issue with the overdrive clutch, or worn components.
Good Luck,
Billy
 
  #3  
Old 06-30-06, 09:12 AM
Member
Thread Starter
Join Date: Jun 2006
Posts: 12
It was a used transmission. I'll take the truck out on the weekend and try to get a better description on what exactly it does and when. Hopefully it's a small adjustment as I don't want to put too much into it.....
 
  #4  
Old 07-14-06, 10:51 AM
Member
Thread Starter
Join Date: Jun 2006
Posts: 12
Driving test and second vehicle

Okay, I took it out and there is definitely an occasional slip when the overdrive is engaged. It usually happens when the passing gear is engaged but on occasion at highway speeds as well. Next question. I recently picked up a 1990 f150 xlt Lariot. Runs great but there is a "shudder" felt in the whole truck when you first start it and when you apply a lot of tork to tow something for example. No transmission slip in overdrive though. I'm wondering if it's as simple as the motor mounts? There is no problem starting and all sparks seem to be firing in sequence etc.....
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes