1993 jeep 4.0 floods at idle

Reply

  #1  
Old 03-11-07, 09:41 AM
W
Member
Thread Starter
Join Date: Mar 2007
Posts: 1
Received 0 Votes on 0 Posts
1993 jeep 4.0 floods at idle

i just bought a jeep cherokee from a friend, he's worked on it for quite awhile trying to solve this problem, has new, distributor, o2 sensor, coolant sensor, crank sensor, ambient air sensor, pcm, cat. conv., tps reads .6-.7 at idle and 4.7 wot. map reads good too. it's had to start when cold, possibly because the plugs keep fowling, when it does start, runs great on the road, pull up to a stop it floods and dies but will restart, if you just start it and let it idle, after about 3-4 min. it'll start to miss , flood out and die. any ideas would be appreciated
 
Sponsored Links
  #2  
Old 03-13-07, 08:32 PM
M
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 4,137
Received 12 Votes on 12 Posts
I would lean toward leaky injectors. I would run it, shut it off, let it sit for about five minutes and click the schrader valve on the fuel rail to see if it's held the pressure.
 
  #3  
Old 03-19-07, 09:28 AM
A
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
Received 0 Votes on 0 Posts
yes check fuel presure and for injector leak down when enging shuts down fuel presure should hold if not try and locate bad injector and replace
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: