No Cold air through A/C

Reply

  #1  
Old 04-30-07, 06:41 PM
Member
Thread Starter
Join Date: Jan 2007
Location: Bloomington, IL
Posts: 172
No Cold air through A/C

I think I need to get the A/C system evaluated because I am not getting cold air to blow through the vent when I want to use the A/C. It is either the outside air temp because I think the fan is just running.

I may be out of freon (which means I have a leak....right?), so what would that cost to fix at a repair shop?

I have a 1997 GMC Sierra, and want to know if there is anything I can do on my won before taking it to the shop?

Thanks
 
Sponsored Links
  #2  
Old 04-30-07, 06:48 PM
Member
Join Date: Jan 2007
Posts: 43
sure but not much you can turn on the a/c open the hood and see if the a/c compressor is on if it is you have other problems if it is not more than likely your system is low on freon and needs to be recharged and checked for leaks
 
  #3  
Old 04-30-07, 08:00 PM
Member
Thread Starter
Join Date: Jan 2007
Location: Bloomington, IL
Posts: 172
Where should I look when looking for the compressor? I do not know a ton about vehicles and the stuff under the hood, so the more info, the better in my case. Either way, I will be taking it in, but at least if I can diagnose it, I might be able to save an hour of labor!!
 
  #4  
Old 04-30-07, 08:09 PM
Ed Imeduc's Avatar
Member
Join Date: Aug 2002
Location: Mountain Williams Missouri
Posts: 18,389
Wink

The compressor should be under the hood. You can have the car running and some one turn the AC on. See if the clutch pulls in on the compressor. Thats about it. Id say take it into a shop
 
  #5  
Old 05-10-07, 08:24 AM
Member
Thread Starter
Join Date: Jan 2007
Location: Bloomington, IL
Posts: 172
Guy said I need a new compressor. That plus labor and a freon charge is 650.00 so I told him NO WAY!

I will probably have it done sometime, but not for that price.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'