Nissan 1996 pickup high idle problem

Reply

  #1  
Old 02-02-08, 10:30 PM
Member
Thread Starter
Join Date: Feb 2008
Posts: 3
Received 0 Votes on 0 Posts
Nissan 1996 pickup high idle problem

Could someone steer me in the right direction? I recently cleaned my throttle body with TB cleaner and it ran just fine the first time. Next time it is now idling high about 1300 rpm and also does the initial warm up higher than usual. Some times it nears 1000rpm but never reaches the normal 700-800rpm idle. I am wondering if I pushed a lot of dirt into a small passage somewhere affecting the idle. I have 200,000 miles 2WD manual trans. thanks
 
Sponsored Links
  #2  
Old 02-03-08, 07:46 AM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
Received 0 Votes on 0 Posts
Possibly logged some debris under the seat of the automatic idle speed motor, which would cause a higher than normal idle speed. Check on side of your throttle body, for idle motor location, and you should see a port adjacent to it, inside the throat of the throttle body. Turn A/C on which should cause the idle motor to speed engine up. When it speeds up, concentrate you cleaner spray at that port (hole) for a few seconds, to try cleaning it out. No gaurantee that's the problem, but it's where I would start, just in case. (try the simple things first right?) Maybe a good blast of air in that port wouldn't hurt either. If it appears easy to remove the idle motor, do so for better cleaning of both, seat & plunger. Be careful to watch for an "O" ring or whatever when motor comes off.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: