Ranger will not start

Reply

  #1  
Old 05-07-08, 05:58 AM
Member
Thread Starter
Join Date: May 2008
Posts: 3
Ranger will not start

I traded for a 1987 Ford Ranger 4X4 2.9 fuel injected. The only way I have been able to get it to start is to spray gas into the plennum. Fuel pumps are running with 38 lbs fuel pressure at the fuel rail. Changed injecters but no start. HELP!!!!!!!!!!
 
Sponsored Links
  #2  
Old 05-08-08, 12:13 PM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
will it stay running after you put fuel in plenium or dose it shut off ?
have you checked injecto control with a noid light ?
 
  #3  
Old 05-12-08, 02:11 PM
ukrkoz's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jan 2008
Posts: 222
All internal combustion engines require fuel pressure to operate. One of the most popular reasons for a fuel system to fail is the fuel pump. This cause's the fuel pressure to drop and engine to stall or not start at all. To check the fuel pump pressure, remove the fuel rail pressure inspection port and attach a fuel pressure gauge. Fuel pressure reading's vary depending on the system your in our vehicle, but most throttle body injection cars (TBI) are between 13 psi and 17 psi. and most (DPI) direct port inject systems are between 40 psi and 55 psi.


so you are slightly low on pressure, if it's measured right. considering age, i'd start with fuel injectors cleaning, replacing fuel filter, and checking on air filter. checking on spark plug quality, not if it's "present" won't hurt either.
 
  #4  
Old 05-14-08, 06:44 AM
Member
Thread Starter
Join Date: May 2008
Posts: 3
Ranger will not start

I have checked everything I can think of, howerver I have found out that the Relay does not work when the Switch is turned on. I have checked wiring, and found nothing. I took the cover off of the relay and engaged it manually. Before I was turning the fuel pumps on with a wire from the Battery. I used a regular DC Light tester on the injector wiring and they do have current, but the light does not pulse. The engine quits when the fuel I spay in the Plenum runs out.
 
  #5  
Old 05-14-08, 10:28 AM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
sounds like the computer is not controling injectors you have got to get a niod light to check flash have you ever had codes read
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'