88 chevy 1500 running rich

Reply

  #1  
Old 05-14-08, 04:23 PM
Member
Thread Starter
Join Date: Jul 2005
Posts: 71
88 chevy 1500 running rich

how do i lean it out. 350 5.7 4x4.
 
Sponsored Links
  #2  
Old 05-15-08, 07:24 AM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
a tad bit more information may help
 
  #3  
Old 05-15-08, 08:47 AM
mikeTN's Avatar
Member
Join Date: Dec 2007
Location: Nashville
Posts: 635
Question

Originally Posted by lawnmowerkid16 View Post
how do i lean it out. 350 5.7 4x4.
not enough info. however, if it just started, it sounds like the choke may be stuck. leaning out the fuel should not be necessary. air filter clean? running rich: black smoke? poor performance? both?
 
  #4  
Old 05-16-08, 09:20 PM
Member
Thread Starter
Join Date: Jul 2005
Posts: 71
sorry about that.

heres the situation i just bought the truck and it has not ran right since i got it. it doesnt blow any smoke, but its running really rich i can smell it in the exhaust.(stong smell of gas...) the guy i bought it from said it was rebuilt about 20,000 miles ago so id multiply that by 3 at the max and figure its probably got about 60,000-70,000 on the engine. the truck its self has like 370,000. tranny was just rebuilt so its got absoultly nothing to do with it. when the truck idles it idels high then low then high then low and so on.... when i drive the truck throttle response is poor unless i get it at a certain point. starts in about a 2 second crank time. not right up but still pretty quick. its got the tbi on it and i cant find a single screw to adjust. i dont know this carb very well. what needs to be done? im good with lawn mower engines but i havent learned vehicle engines yet.i dont know if its normal i get about 10 mpg.
 
  #5  
Old 05-18-08, 04:22 PM
Member
Join Date: Dec 2001
Posts: 2,538
your fuel ratio is computer controlled you might check codes for starters but a rich or lean condition could be caused by alot of things based on your description of idle surging up and down would probably check ignition timing, check egr valve to make sure its not stuck open, and fuel pressure
 
  #6  
Old 05-19-08, 03:32 AM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
had that problem

Had that problem on a 89 with same engine turned out to be coolant temp sensor. You can test it with a multimeter. Engine would run rich cause it was in open loop mode all the time.
 
  #7  
Old 05-20-08, 02:07 PM
Member
Join Date: Nov 2001
Location: North Texas
Posts: 2,345
question

Any codes? you can check codes with a paper clip on that year truck by counting the flashes. Also the tps could be bad also causing bad idle and hard starts.
 
  #8  
Old 05-21-08, 12:36 PM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
to check codes jump pins a&b in aldl conector under dash drivers side just to clarify for michael van
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'