Sluggish Acceleration

Reply

  #1  
Old 09-21-08, 05:53 AM
Member
Thread Starter
Join Date: Sep 2008
Location: Northern Texas
Posts: 2
Sluggish Acceleration

I have a 1992 Olds Delta 88 that has recently started accelerating sluggishly. It also is somewhat sluggish when I idle like at a stoplight. Could this be the fuel filter or could it be a more major problem?
 
Sponsored Links
  #2  
Old 09-21-08, 06:02 AM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,695
Sounds like fuel system. Start with new fuel and if the filter hasn't been changed in a while do that. If that doesn't take care of it, the fuel pressure at the rail would need to be checked.

If the pressure showed up low you would be looking at a fuel pump or pressure regulator.

Other basic tune-up things like plugs/wires/air cleaner can cause similar problems. Also a plugged catalytic converter or some of the electronic gizmos like oxygen sensor. But I would start with the easiest and cheapest.
 
  #3  
Old 09-21-08, 07:25 AM
Member
Thread Starter
Join Date: Sep 2008
Location: Northern Texas
Posts: 2
Thanks for answering so quickly. I hope it is something as minor as the fuel filter. We are going to try that today along with new plugs and some fuel injection/carbarator cleaner and see if that helps.
 
  #4  
Old 09-21-08, 07:35 AM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,695
Yeah, a lot of times it's the small stuff, because the big stuff is built to last. Do the easy/cheap first.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'