Thetford Aqua-Matic RV Toilet

Reply

  #1  
Old 10-23-08, 10:54 AM
Member
Thread Starter
Join Date: Oct 2008
Location: Dayton, OH
Posts: 2
Red face Thetford Aqua-Matic RV Toilet

I have an Aqua-Matic Starlite toilet in my motorhome that worked properly in July. This past weekend it started leaking fresh water on the floor. I disconnected the water hose at the camp site so there wasn't any pressure on the syatem. Then each time we turned on the DC water pump in the gally, it would leak. [B]I would like information as to what might be leaking. It doesn't leak into the inside of the toilet just underneath then seeps out on to the floor.

Frito
 
Sponsored Links
  #2  
Old 10-23-08, 12:09 PM
Member
Join Date: Oct 2004
Location: Ontario
Posts: 539
remove the lower cover and look may be just a lose fitting or bad water line conection
 
  #3  
Old 10-24-08, 07:23 AM
Member
Thread Starter
Join Date: Oct 2008
Location: Dayton, OH
Posts: 2
There is no lover cover on this model. You have to remove ths whole unit to see what is inside. That is the reason for me to ask the question. I need information that may lead me to a possiable solution with out having to remove the whole unit. Thanks Doc.
Frito
 
  #4  
Old 10-31-08, 07:43 PM
Member
Join Date: Jan 2006
Location: Ontario, Canada
Posts: 759
You did try reaching behind and following line up to toilet & try tightening the fitting connection ?
 
  #5  
Old 11-15-08, 06:30 AM
Member
Join Date: Nov 2008
Location: Washington state
Posts: 2
Had the same problem this last spring. The connector where the water line enters in the backside had popped loose and would leak badly soaking the carpet. I just bought a whole new toilet but it is repairable and parts are available I think if fittings happen to be damaged. You might be able to just reassemble it and tighten it.
Paul
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
'